Absolventská práce

Paint Shop Pro verze 7.01

WWW prezentace obce Třebovice v Čechách

Vypracoval: Martin Krpata, 2001

PODĚKOVÁNÍ

Děkuji PeadDr. Petru Pexovi za hodnotné rady a odborné vedení během mé práce.
51.
Úvod


51.1.
O softwaru PSP 7.01


61.2.
Náhled do PSP 7.01


72.
Nový obrázek


82.1.
Rozměry obrázku (Image dimension)


92.2.
Charakteristika obrázku (Image Characteristics)


93.
Otevření obrázku


93.1.
Open file (klasické otevření)


103.2.
Browser (prohlížeč)


113.3.
Drag and drop


113.4.
Import


123.5.
Screen Capture


124.
Panel barev


134.1.
Foreground / Background colors (plná barva popředí / pozadí)


134.2.
Paleta barev


144.3.
Styly


144.4.
Textury


154.5.
Lock (zamknout)


154.6.
Preview


154.7.
Recent colors (přednastavené barvy / naposledy použité)


164.8.
Dialogové okno pro výběr barvy


175.
Rulers, Grid, Guides (pravítka, mřížka, vodítka)


185.1.
Pravítka


195.2.
Mřížka


205.3.
Vodítka


216.
Panel kreslících nástrojů


226.1.
Nástroje se společným Tool Options


256.2.
Vektorové nástroje


306.3.
Označovací nástroje


336.4.
Zbývající nástroje


387.
VRSTVY


397.1.
Omezení vrstev


397.2.
Paleta vrstev


407.3.
Dialog vlastnosti vrstvy


417.4.
Kreslíme pomocí vrstev


438.
UKLÁDÁNÍ OBRÁZKŮ – Save / Save as


448.1.
Trocha teorie o webových formátech


468.2.
Gif Optimizer


478.3.
Jpg optimizer


478.4.
PNG optimizer


489.
Batch Conversion (dávková konverze)


4910.
Web toolbar


5010.1.
Image Mapper (generátor klikacích map)


5310.2.
Image slicer (rozřezávač obrázku) a Animation shop


5911.
Jak nakreslit...


6011.1.
Nadpisy


6211.2.
Tlačítka


6612.
Praktická část


6613.
Závěr




1. Úvod

Tato absolventská práce se bude zabývat programem Paint Shop Pro (PSP) verze 7.01. Chtěl bych díky této práci čtenáře naučit základní ovládání programu a popsat novinky vůči verzi 6.0. Též se zaměřím na grafiku směřující spíše k webu, než k upravování fotografií, které též tento produkt dokáže upravovat. Tuto práci jsem si vybral, protože v ČR je absence jakéhokoliv českého manuálu či popisu PSP 7.01.   

V následujících kapitolách popíši, jak si vytvořit nový obrázek, popř. jakými způsoby můžete otevřít existující, dále popíši jednotlivé nástroje, jak už pro kreslení, výběr, či úpravy obrázků. Též se budu věnovat vrstvám a ukáži vám, jak kreslit nadpisy, či webová tlačítka. Pokusím se popsat všechny vylepšení PSP 7.01 (alespoň pomocí přikladu), které se vztahují k web designu.

1.1.  O softwaru PSP 7.01

Paint Shop Pro od firmy Jasc Software, Inc. obsahuje nástroje, které jsou potřeba pro vytváření, editováni, retušování vašich obrázků. Vzhledem k jeho ceně a tomu, že se jedná o shareware (můžete si předem vyzkoušet 30-ti denní verzi), tak je to velmi kvalitní grafický editor, který je od verze k verzi lepší a lepší. V mnoha recenzích na internetu je porovnáván s editorem Adobe Photoshop. PSP dostalo přezdívku Photoshop pro chudé. Tato přezdívka je velmi výstižná, neboť zakoupení PSP stojí něco okolo 4000,- a zakoupení Photoshopu stojí něco okolo 25000,-. Bohužel jsem neměl možnost porovnat tyto dva programy, ale v recenzích je psáno, že Photoshop je lepším editorem než PSP, avšak v poměru cena/kvalita vítězí PSP. 

Při porovnání verze 7.01 a verze 6.0 tak je tu mnoho novinek a vylepšení. Všechny nástroje byly vylepšeny mimo jiné  o barevné přechody, přidáno bylo velké množství nových efektů a filtrů. Přibyly též nové typy štětce. Byly též zavedeny vektorové nástroje pro kreslení křivek. (přímka, Beziérova křivka a nebo jednoduše od ruky). Přednastaveny jsou též i tvary např. elipsa, obdélník, čtverec, hvězdy, n-úhelníky, šipky, tlačítka pro web a další. Vylepšeno též bylo editování textu, které nyní umožňuje zpětné editování (u vektorového vykreslení). Na obrázku můžete použít najednou vektorovou i rastrovou vrstvu, ale vektorová se pochopitelně vloží do vlastní vrstvy. 

Pro web design přibyly nástroje Image Slicer (rozřezávač obrázků), který obrázek rozřízne a následně vygeneruje htm (html) kód, ve kterém tento obrázek poskládá znovu dohromady. Jako další nástroj přibyl Image Mapper (klikací mapa). Tento nástroj slouží k vytvoření klikací mapy na obrázku (snadno a rychle), což se dá použít např. pro vytvoření odkazů na jednotlivá města na mapě. Tyto dva nástroje podporují i vytvoření rollover efektů – např. po přejetí myší nad určitou oblastí obrázku se změní přejížděný obrázek. Jako další vylepšení je rozšířená optimalizace výstupu obrázku do 3 formátu pro web (gif, jpg, png). Též byl vylepšen Animation Shop (příloha k PSP) pro vytváření animovaných gifů, když ovšem porovnám vylepšení PSP a Animation Shopu, tak na Animation Shop tak trochu zapomněli. I tak je ale Animation Shop plnohodnotným programem, který výborně postačí na tvorbu animovaných bannerů (na to má dokonce speciální odkaz v menu), nebo jiných menších animací. 

1.2.  Náhled do PSP 7.01

Na obrázku č. 1 je vidět spuštěné PSP s rozpracovaným obrázkem. Jak už je na první pohled vidět, tak vůči verzi 6.0 tu přibyli změny. Panel barev přibral položky: styly a textury. Na panelu kreslících nástrojů přibyly nástroje, a celkově je trošičku jiný vzhled. Sám mohu potvrdit, i vy, co jste dělali s verzí 6.0 a přešli jste, popř. teprve přejdete na verzi 7.01, mi jistě dáte za pravdu, že se s ní pracuje mnohem jednodušeji a lépe. 
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2.  Nový obrázek

Než začnete kreslit, musíte si vytvořit nový obrázek popř. otevřít existující. Nový obrázek vytvoříme sekvencí činností File (Soubor) > New (Nový). Otevře se dialog viz obrázek č. 2. 

Musím podotknout, že každý nový obrázek obsahuje základní rastrovou vrstvu Background, ale o vrstvách až v kapitole č. 7.  
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2.1.  Rozměry obrázku (Image dimension) 

2.1.1.  Šířka (width) a výška (height) 

Lze zadat v pixelech, centimetrech nebo v palcích. Jedná se o velikost obrázku. Vždy je lepší dávat větší rozměr, než menší, neboť nemusíte odhadnout budoucí velikost obrázku. A ostatně lze výsledný objekt vyříznou, popřípadě zkopírovat do nového.

2.1.2.  Rozlišení (resolution)

Obrázek se  skládá z malých čtverců známých jako pixel. Obrázek, který má více pixelů (bodů) na určitou plochu, má vyšší rozlišení, zobrazuje více detailů, a samozřejmě výsledný soubor je větši a zabírá více místa. Rozlišení obrázku je tedy počet prvků na jednotku délky obrazu, a to je obvykle pixel na palec (ppi). 

Když budeme prezentovat tento obrázek na webu, jeho rozlišení by mělo být 72ppi.

2.2.  Charakteristika obrázku (Image Characteristics)

2.2.1.  Barva pozadí (Background color) 

Zde si můžeme vybrat z mnoha položek, a to buď konkrétní barvu (5 barev – bílá, černá, modrá, zelená, červená), nebo plnou barvu popředí, popřípadě plnou barvu pozadí. Tuto barvu vyberete kliknutím na panel barev (ale musíte ještě před otevřením dialogu New Image, popis panelu barev nalezete v kapitole č. 4. ). Jako další položka je zde Transparent (průhledná) Toto se využívá hlavně u webové prezentace obrázku – při zobrazení je vidět jen obrázek samotný a ne jeho pozadí. 

2.2.2.  Hloubka barev (Color depth)

Hloubka barev, udává počet barev, které je pixel schopen zobrazit. Při hloubce 1bit je možné zobrazit pouze 2 barvy, při 8 bitech 256barev atd. Doporučení je jasné, 24bitů, neboť mnoho efektů, deformací, filtrů a barevných přizpůsobování lze použít pouze na této hloubce, nebo na obrázku v odstínech šedi (Greyscale Image). Je možné u otevřeného obrázku zvýšit popřípadě snížit hloubku barev? Ano, a to v menu Colors (barvy) > Increase color depth (zvýšit) nebo Decrease color depth (snížit). 

3.  Otevření obrázku

Zde existuje mnoho způsobů, jak můžete obrázek otevřít.

3.1.  Open file (klasické otevření)

I zde je více cest, jak otevřít:

a) [image: image3.png]


klávesovou zkratkou (CTRL+O)

b) kliknutím na ikonu 
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přes menu File (soubor) > Open (otevřít). 

Doporučení: zaškrtněte si Show Preview (ukáže se vám aktuálně označený soubor). Po jedné z této činností (a(c), se vám otevře dialogové okno, viz obrázek č. 3.

3.2.  Browser (prohlížeč)

Tento prohlížeč je přímo implementován v PSP. Možnosti spuštění:

a) zkratková klávesa CTRL+B

b) menu File (Soubor) > Browse (prohlédni, procházej)

c) nebo z předchozího dialogu (viz obrázek č. 3), browse

Otevření se provede buď pomocí klávesy Enter, nebo pomocí dvojkliku. Pokud potřebujete otevřít více obrázků najednou, použijte při označení klávesu Shift (popř. CTRL). Prohlížeč též podporuje mnohé operace, viz pravé tlačítko myši na obrázku a mimo něj. Tyto operace jsou zcela jasné a nebudu se tedy o nich [image: image5.png]Plocha
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zmiňovat.

3.3.  Drag and drop

  Můžete použít i tento způsob: z nějakého správce souborů (např. Windows Commander) uchytit levým tlačítkem myši a přetáhnout do PSP a upustit (drop). Je též možné pustit na ikonku na pracovní ploše Windowsu. Samozřejmě je možné otevřít i více obrázků najednou pomocí Shift (Ctrl).

3.4.  Import 

  Importovat lze ze 3 míst. Ze scanneru, digitálního fotoaparátu a nebo Screen Capture (uloupení obrázku). Bohužel jsem neměl možnost ověřit nastavení a funkčnost scanneru, či digitálního fotoaparátu (pro majitele viz help Creating Images > Geting Images from Scanners or Digital cameras).

3.5.  Screen Capture
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Je možné sejmout momentální pracovní plochu. Nastavení je v menu File > Import > Screen Capture > Setup (viz obrázek č. 5). 

Capture – jaká oblast se má uloupit

Active capture using – čímž se spustí uloupení obrázku

Option: 

a) Include cursor (včetně kurzoru)

b) Multiple captures (více nasobné uloupení)

Bohužel, ale můžete funkci Capture použít pouze na aplikace podporující OLE (Object Linking and Embedding).

4.  Panel barev

I zde je znatelné vylepšení od verze PSP 5 a 6. Gradient (sklony), Pattern (vzory) a textury jsou nyní přístupné na panelu barev. Na rozdíl ve verzích 5 a 6, kde byly přístupné až pomocí jednotlivého kreslícího nástroje. 

4.1.  Foreground / Background colors

(plná barva popředí, pozadí)
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Už z názvu vyplývá, že se toto nastavení využívá například k vytvoření nového obrázku, kde si vybíráte barvu pozadí (viz. kapitola č. 2.2.1. ), ale to není vše, tento výběr je základem pro všechny kreslící nástroje. Kapitoly 4.1. –  4.6. se vztahují k obrázku č. 6. (4.1. = 1, …) 

Změnit lze 3-mi způsoby (u všech způsobů záleží jakým tlačítkem kliknete): 

a) pomocí kapátka, které se objeví po najetí myší na paletu barev (2.), 

b) kliknutím na 1.

c) pomocí kapátka (Dropper) z panelu nástrojů, když kliknete na otevřený obrázek

U způsobu a) a c) si můžete ověřit vybíranou barvu (6.)

4.2.  Paleta barev

[image: image8.jpg]


Zde jsou vyobrazeny dostupné barvy pro daný obrázek. Obrázek lze konvertovat: menu Colors > Increase Color Depth (zvýšení), Decrease Color Depth (snížení, POZOR! daný obrázek ztrácí kvalitu). Základní možnosti barevné hloubky (viz obrázek č. 7).

4.3.  Styly
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Následující obrázek vysvětluje vše (obrázek č. 8). Použil jsem obdélník nakreslený pomocí Preset Shapes (bude popsáno v kapitole č. 6.2.3. ).

4.4.  Textury

[image: image10.jpg]


[image: image11.jpg]Teutures

> Bez textury

S texturou



Textura se dá popsat jako povrch, určitého objektu, který pak vypadá jako např. kůra od stromu, zeď, ... V Paint Shop Pro se pomocí textur dají tvořit různá „kouzla“, neboť existuje mnoho možností jak využít textury (např. se dají kombinovat s různými efekty, ...). Při použití textury záleží na vybraném stylu viz kapitola č. 4.3. . Následující 2 obrázky (obrázky č. 9 a 10) ukazují vybrání textury a vytvoření pomocí ní obdélník. Pozn. když si vyberete položku s texturou (viz č. 10), pak nezapomeňte do ní nahlédnout – rozbalí se výběr textur... 

4.5.  Lock (zamknout)

Veškeré změny na panelu barev se nastavují k aktuálně označenému nástroji na panelu kreslících nástrojů! Takže, když si například nastavíte panel barev pro nástroj Draw, tak je nastaven pouze pro něho. Po přepnutí na Preset Shapes, se přepne nastavení k tomuto nástroji. Toto právě řeší Lock. Když jej zaškrtnete, přenáší se aktuální nastavení i k dalšímu nástroji...

4.6.  Preview

Tato část panelu barev slouží k náhledu aktuálně vybírané barvy pomocí kapátka (Dropper). Jak už jsem se jednou zmínil, lze kapátko použít k sejmutí barvy, buď z palety barev, nebo z otevřeného obrázku. Číselné hodnoty mohou být dvojího typu: RGB (červená, želená, modrá) nebo HSL (barva, nasycení, světlost). Toto nastavení je v menu > File > Preferences > General Program Preferences > záložka Dialogs and Palettes > menu Color Palette > Display colors in RGB format nebo display colors in HSL format. 

4.7.  Recent colors 

(přednastavené barvy / naposled použité)
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Jestliže kliknete pravým tlačítkem myši na plnou barvu popředí / pozadí, zobrazí se vám výběr barev, a to výběr z deseti základních + deset naposled použitých (viz obrázek č. 11). 

Jestliže Vám tyto barvy nestačí, popřípadě potřebujete zadat ručně hodnotu RGB, klikněte na Other...

4.8.  Dialogové okno pro výběr barvy

Mouhou být dva druhy. Implicitní je od firmy Jasc, a druhé je klasické, jako ve Windows (to si můžete zapnout položkou Use standard Widnows color picker). Cesta je již známa z kapitoly č. 4.6. , kde jsme nastavovali RGB nebo HSL. 
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Basic color: zde máte na výběr ze 48 implicitních barev 

Custom colors: ruční nastavení barvy, a to buď pomocí RGB hodnot (např. plně 

červená je Red: 255, Green: 0, Blue: 0), nebo pomocí HSL (barva, nasycení, světlost).

Link colors: zapíná zobrazení linek u nastavení HSL v aktuálně vybraném odstínu barvy 

HTML code: při výběru barvy dochází k automatickému přepočtu do HTML kódu a naopak. Je velice vhodné použít tento kód, například k zadání barvy pozadí u html stránky. Můžete si zjistit, díky tomuto dialogu, například i barvu určitého obrázku a přizpůsobit k tomu barvu pozadí HTML stránky. Postup je následující: vyberte z panelu kreslících nástrojů kapátko (Dropper) a vyberte si levým tlačítkem určitou barvu, po té vyvolejte dialogové okno pro výběr barvy (opět levým tlačítkem) – daná barva se přenese do dialogu a v položce HTML code máte hledaný kód. Ten už jen přenesete do HTML stránky (ale to už nepatří k PSP...).

New / Old color: 

a) new color – aktuální nastavená barva 

b) Old color – výchozí barva při spuštění dialogu

5.  Rulers, Grid, Guides 

(pravítka, mřížka, vodítka)

K přesnému kreslení jakýmkoliv kreslícím nástrojem jsou potřebné minimálně 2 z těchto 4 základních možností: pravítka, mřížka, vodítka a kvalitní myš. Proto uvádím tuto kapitolu ještě před kreslícími nástroji. 

Díky pravítkům si můžete ověřit aktuální pozici (nezapomeňte na stavový řádek vlevo dole), mřížka slouží ke kontrole, popřípadě k přichycení nástroje (viz obrázek č. 13) a vodítko (jak už vyplývá z názvu) slouží k vedení kreslícího nástroje (jako tabulka, ale s možností umístit vodítko kamkoliv a přemísťovat).
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5.1.  Pravítka
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Lze zapnout v menu > View > Rulers nebo zkratkovou kombinací kláves CTRL+ALR+R. Nastavení pravítek je v menu > File > Preferences > General Program Preferences > záložka Rulers and Units viz obrázek č. 14. 

5.1.1.  Položka Rulers:

Display units (jednotky na pravítcích): Pixels (body), Inches (palce), Centimeters

Black on white / toolbar colors ( pozadí pravítek ): černé na bílém / windows barvy

5.1.2.  Položka resolution:

Default resolution (imlicitní rozlišení pravítek): doporučuji stejné jako obrázek.

5.2.  Mřížka

Zobrazení pomocné mřížky lze zapnout v menu > View > Grid, nebo kombinací kláves CTRL+ALT+G. Tuto mřížku lze použít ke 2 činnostem. Jako pomocnou nebo jako přichytávající. Zapnutí / vypnutí přichytávání je v menu > View > Snap to Grid (zapnout lze pouze se zapnutou mřížkou). Hustota mřížky se nastavuje ve stejném menu a ve stejné záložce jako pravítka (viz obrázek č. 14). 

5.2.1.  Výchozí nastavení tabulky (Položka grid)

Units: zde si můžete vybrat v jakých jednotkách chcete zadat

Horizontal Spacing a Vertical Spacing: rozestup jednotlivých dílů tabulky

Link colors: barva linek tabulky

5.2.2.  Lokální nastavení tabulky: Grid and Guide Properities
Naleznete v menu > View > Change Grid and Guide Properties (viz. obrázek č. 15). Nastavení zde je pouze lokální, tudíž se vztahuje pouze k aktuálně otevřenému obrázku. 
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5.2.2.1.  Jsou zde tyto funkce (položky):

Grids: viz. předchozí odstavec (položka grid (výchozí nastavení))

Snap (přichycení): zde je výběr možností, jak lze přichytávat vybraný kreslící nástroj

Snap influence in pixels: jedná se o vzdálenost v bodech, do které bude kreslící nástroj přichytáván

Snap to grid: přichytávání k mřížce

5.3.  Vodítka

Vodítka jsou podobná mřížce, neboť mřížka je pravidelné seskupení vodítek. Tudíž můžeme říci, že z vodítek se dá složit mřížka, ale ne naopak! 

5.3.1.  Vytvoření vodítka

Vodítko se dá vytvořit tímto způsobem: 

1) Zapnutí vodítek všeobecně v menu > View > Guides. Nezapomeňte zapnout i pravítka, neboť bez nich se nedá přidat nové vodítko.

2) Přidání vodítka: klikněte levým tlačítkem na pravítko a táhněte směrem do obrázku. 

3) Pozice vodítka, zrušení vodítka, barva vodítka jsou na obrázku č. 13.

4) Barva všech vodítek – pro aktuální obrázek viz obrázek č. 15, položka Set color of all current guides

5) Barva všech vodítek – výchozí pro všechny nové obrázky: stejné menu jako pravítka, položka Guide > Line color

6) Zapnout přilepování na vodítko, se provede stejným způsobem jako u tabulky,  položkou Snap to guide 

7) Zrušení vodítka: uchopíte levým tlačítkem a přetáhnete zpět na pravítko
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Panel kreslících nástrojů

Všechny tyto nástroje se vztahují k Tool Options (panel nátroje), kde je jejich nastavení. Zapnete klávesovou zkratkou O.

6.1.  Nástroje se společným Tool Options

[image: image18.jpg][RQiEsmPs /AFRNSIFAOCATB|

10329188 323lq0
sadeys joseid
meig

oL

114 poory
usniquy

seqny aunjoig
1esesg

1enowey yojesog
yanojey
190e[doy 10]0D
ysnig auo|d
ysnigjuied
1eddosg

puem o16ew
uonoejes pueyessy
uonosjes

1m0

doig
uonewojeq
wooz
moury




Paint Brush (štětec), Clone Brush (klonovací štětec), Retouch (retuš), Eraser (guma) a Airbrush (sprej), mají stejné položky v Tool Options (nastavení nástroje) viz obrázek č. 17. 

Shape (tvar)
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Váš výběr pro tento popup je následující: Square (čtverec), Round (kruh), Left Slash (levé lomítko), Right Slash (pravé lomítko) viz obrázek č. 18.

Size (velikost)

Velikost vybraného tvaru v pixelech 0 – 255.

Hardness (tvrdost okrajů)
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Toto nastavení určuje jak „tvrdé“ okraje budete mít, když použijete jeden z již zmíněných nástrojů (štetec, ...) viz obrázek č. 19. Na obrázku je použito nastavení tvrdosti okrajů na 100%, 75%, 50%, 25% a 0%.

Opacity (průsvitnost)
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Nastavení průsvitnosti určuje, jak hodně bude zakrývat barva obrázek. Následující obrázek č. 20 vysvětluje vše. Nastavení štětce je Hardness 100% a Opacity na 100%, 75%, 50%, 25%.

Step (krok)
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Při tahu štětce určuje Step, jak často se bude nanášet barva. Následující obrázek č.21 objasní vše. Nastavení kroku štětce je na obrázku nastaveno od shora dolů na 25, 50, 75, 100 při velikosti 20. A znamená to, že při kroku 100 a velikosti 20 se bude barva nanášet jednou za 20 bodů. 

Density (hustota)
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Hustota určuje, kolik barvy se bude nanášet při každém kroku (viz. obrázek č. 22).

6.1.1.  Paint Brush (štětec)

Tento nástroj je velice známý z jiných programů, v předchozí kapitole č. 6.1.  má vysvětlené nastavení – společné Tool Options. Různými kombinacemi s panelem barev lze dosáhnout velmi zajímavých efektů. 

Jak můžete kreslit:

a) volně, když nezáleží na přesnosti

b) přichytáváním viz kapitola č. 5.  – Rulers, Grid, Guides

6.1.2.  Clone Brush (klonovací štětec)

Jak už z názvu vyplývá, jedná se o štětec, který dokáže kopírovat oblast a vykreslovat ji s nastavením štětce. Dokáže kopírovat dokonce i z obrázku do obrázku. Je velmi vhodný např. na vymazávání nevhodných objektů viz obrázek č. 23, kde jsem překryl křídlo rogala okolní oblohou. Používá se tak, že nejprve kliknete pravým tlačítkem myši na místo, ze kterého chcete klonovat (kopírovat) a pak už jen kreslíte levým tlačítkem na místě, kam se má tato sekce překreslit. Od puštění a znovu začátku kreslení záleží na tom, jestli je štětec Aligned (zarovnán) nebo Non-Aligned (nezarovnán) – toto nastavení najdete v Tool Option ve druhé záložce. Když není zarovnán, je znovu opětovné kreslení prováděno znovu a znovu ze stejného místa. Když je zarovnáván, je místo, odkud se bude kreslit, zarovnáváno vůči aktuální pozici kurzoru.

[image: image24.jpg]Image Mapper

UAL:  [rtp://ceskartebova

Aot [Ceka Trsbove

Taiget: [op
Lot 174 Top 218
Right 242 Botom 248
~Rolavers

[~ Eomat

Opiinize Image.

Riollover Creator.. | Riollover enabledt: no

Saye Setings Load Setings

o e |

% a ZnZ\ a

: |

Cos | Hep | Ereforences. |

Close.





6.1.3.  Retouch (retuš)

Tento nástroj slouží k dolaďování oblastí. Opět stejné nastavení jako štětec, ale přibylo zde popup menu, ve kterém si vybíráte, co má Retouch nástroj dělat např. zesvětlovat, ztmavovat, rozmazávat, ... (vyplývá z překladu).

6.1.4.  Eraser (guma)

Vymazává danou oblast barvou, jenž si zvolíte na panelu barev (nevyužívá textury). 

6.1.5.  Airbrush (sprej)

Postupné nanášení barvy po kapičkách (jako sprej). Toto je poslední nástroj, kde je stejné nastavení, jako u štětce. 

6.2.  Vektorové nástroje

V PSP umí s vektorovou grafikou pracovat 4 nástroje. Draw (tužka), Preset Shapes (přednastavené tvary), Text. Avšak tyto 3 nástroje umožňují nejen kreslení vektorové grafiky, ale i rastrové. Pro označení vektorového objektu slouží Object Selector. 

Vektor v PSP, je objekt, který má svůj začátek, konec, směr a další údaje, které udávají např. šířku čáry. Díky těmto údajům složí program PSP jednoduše daný objekt s výhodou, že tento objekt neztrácí kvalitu při editování (změny směru, velikosti, ...). Dokonce umožňuje např. připojit text k lince apod. Při vytvoření vektorového objektu se automaticky vytvoří vektorová vrstva. 

Tímto jsem předběhl dobu, vrstvy nebyly vysvětleny, pro nezasvěcené jsou vysvětleny v kapitole č. 7. 
6.2.1.  Text
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Základní a jediný nástroj vykreslení textu v PSP. Tento nástroj má velmi mnoho možností a s kombinací některých efektů, se dají s ním vytvářet např. velmi zajímavé nadpisy (viz kapitola č. 11.1. ). Na obrázku č. 24 je dialog pro vložení textu se stručným popisem. Na obrázku č. 25 jsou vidět některé výstupy tohoto nástroje.

Kearning: vzdálenost jednotlivý písmen vůči sobě

Leading: vzdálenost řádků

Create as: 

a) Vector – vytvoří vektor ve vektorové vrstvě

b) Selection – vytvoří plovoucí výběr (selekci) ve tvaru zadaného písma

c) Floating – plovoucí text, v rastrové vrstvě

Preview: promítnutí vzhledu do obrázku 
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6.2.2.  Draw (tužka)
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Pomocí tužky můžete kreslit linky, křivky, šipky, apod. Následující obrázek č. 26 ukazuje možnosti tužky. Opět je možné kombinovat možnosti linky s panelem barev. 
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Je též možné zkombinovat tužku a text dohromady, lépe řečeno přilepit text k lince. Tato činnost se provádí takto: nakreslete si vektorovou linku pomocí tužky. Vyberte si nástroj Text a ukažte na linku. Změní se vám kurzor a klikněte. Zobrazí se klasické dialogové okno od nástroje Text, avšak po potvrzení dialogu se text přichytí k lince. Text se zarovnává dle toho, jak nastavíte (vlevo = začíná na začátku linky, center = střed). Toto je vidět na obrázku č. 27. 

Je možné mít pouze text bez linky, takto zarovnaný? Ano je. Linka tam sice zůstane, ale je průhledná. Pomocí Layer Palette si označte pouze linku a v Properties (pravým tlačítkem na lince) odškrtněte Visible...      

6.2.3.  Preset Shapes (přednastavené tvary)

Tento nástroj bych přirovnal částečně k tubám (Picture Tubes), a to ve směru snadno a rychle (popsáno v kapitole č. 6.4.5. ). Zde je mnoho přednastavených tvarů, které můžete kreslit, buď jako rastr nebo jako vektor. 

Když použijete vektorovou grafiku, je možné tyto přednastavené tvary nadále upravovat. Je zde k výběru ze základních tvarů, jako je např. obdélník, trojúhelník, elipsa, ale jsou zde i tlačítka pro web viz obrázek č. 29.         
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Popis obr č. 28 Tool Option pro Preset Shapes

V okénku si můžete vybrat přednastavený tvar. Pokud necháte zaškrtnuté Retain style, bude kreslený objekt stejný jako v okénku pro výběr přednastaveného tvaru. Jinak bude kreslený objekt vykreslen podle aktuálního nastavení panelu barev. 

Doporučení: pokud budete kreslit jednoduchý tvar, jako je např. obdélník, nezaškrtávejte položku Retain Style. Pokud však budete kreslit, např. tlačítko pro web, nechejte zaškrtnuté, a tento objekt zakreslete jako vektor. Tento objekt se pak bude skládat z jednotlivých vrstev (stín, ...). Následně poupravte jednotlivé vrstvy dle vkusu. V dialogu, který naleznete v Layer Palette > výběr jednotlivé části objektu > pravé tlačítko myši > Properties, smíte upravit barvu výplně, textury, ... Vrstvy jsou popsány v kapitole č. 7. 
6.2.4.  Object Selector

Tento nástroj má největší charakteristické vlastnosti pro práci s vektory. Díky tomuto nástroji smíte nejen označovat vektorové objekty, ale také je upravovat (Node Edit).   
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Při označeném objektu smíte měnit jeho velikost, popřípadě sním otáčet za úchytné body. Když stisknete na tomto objektu pravé tlačítko myši při vybraném nástroji Object Selector, rozbalí se menu, pomocí kterého smíte s vektorovým objektem dělat prakticky cokoliv. Smíte např. exportovat tento objekt do přednastavených tvarů (Export Shape), nastavit barvy, styly a textury (Properties), ... Jedna z položek je Node Edit (úprava uzlů). Díky této funkci smíte přetvářet jednotlivé části objektu. Když se jedná o rovnou linku – smíte měnit její velikost. Když se jedná o křivku, pak smíte měnit velikost, i směr této křivky. Z Node Edit vyskočíte pomocí zkratkové klávesy CTRL+Q nebo pravým tlačítkem myši > Quit Node Editing.   

6.3.  Označovací nástroje 

PSP má k dispozici 3 nástroje. Selection (výběr, klasické tvary např. obdélník, kruh, ...), Freehand Selection (označování „od ruky“), Magic Wand (kouzelná hůlka, automatický výběr). V okamžiku kdy začnete pohybovat s výběrem,  vytvoří se automaticky vrstva Floating Selection (plovoucí označení), po odznačení je tato vrstva smíchána do nejbližší rastrové vrstvy. Díky těmto nástrojům můžete přesouvat, či vystříhávat označené místo (v aktivní vrstvě). Pro označení je v menu položka Selections, kde je nastavení pro aktuální označení. Zde bych chtěl ukázat hlavně položku Modify, kde můžete měnit velikost označení.

Mezi označovací nástroje by se dal zahrnout i nástroj Object Selector, ale jelikož je úzce spjat s vektorovou grafikou, byl již proto popsán v kapitole č. 6.2.4.  

6.3.1.  Společné vlastnosti označovacích nástrojů

Antialias (vyhlazení)

Je možné zapnout u nástrojů Selection a Freehand Selection. Vyhladí hrany označení (výběru), lépe řečeno je malinko rozmaže. 

Feather (okraj)

Je možné zapnout u všech třech nástrojů. Jedná se o to, že vám přidá k označení určitý počet bodů.   

Zvětšování a zmenšování výběru

Smíte provádět pomocí všech tří nástrojů! Na obrázku č. 31 je vidět názorná ukázka. Zvětšování / zmenšování výběru provedete pomocí klávesy Shift / Ctrl a daného nástroje. 
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6.3.2.  Selection (výběr)

Jak jsem již jednou řekl, jedná se o označování pomocí klasický tvarů, jako jsou obdélník, kruh, elipsa, ale také např. šipka. Toto nastavení naleznete v Tool Options. 

6.3.3.  Freehand Selection (výběr „od ruky“)   

Je možné tento nástroj použít 3-mi způsoby. 

a) Freehand („od ruky“): záleží na vaší citlivé ruce

b) Point to Point (z bodu do bodu): postupně se natahují linky z bodu do bodu, dokud nezmáčknete pravé tlačítko myši, pak se spojí poslední bod s prvním a máte označenou oblast

c) Smart Edge (chytrý okraj): tento způsob pracuje obdobně jako způsob z bodu do bodu, ale automaticky vytvoří křivku z bodu do bodu, který jste zvolili. Tato křivka obtéká podle kontrastu a barvy mezi těmito 2-mi body (hledá optimální spojení dle barvy a kontrastu). 

6.3.4.  Magic Wand (kouzelná hůlka)

Tento pracovní nástroj je užíván k automatickému výběru pomocí barvy pixelů (bodů) v obrázku. Můžete si vybrat režim, na kterém bude výběr založen (Match mode). 

Tyto režimy jsou:

a) RGB – označuje podle množství červené, zelené a modré barvy v bodech

b) Hue – označuje body podle jejich odstínu 

c) Brichtness – označuje body podle množství bílé, které ony obsahují

d) All Opaque – označí všechny barevné body, kromě průhledných míst

e) Opacity – vybírá podle neprůsvitnosti bodů vůči síle neprůsvitnosti jednotlivých bodů v okolí

6.4.  Zbývající nástroje

Zbývajícími nástroji, které jsem nepopsal, jsou Picture Tubes (obrázkové tuby), Color Replacer (nahrazovač barvy), Scratch Remover (odstraňovač škrábanců), Flood Fill (kyblík), Deformation (deformační nástroj), Mover (posunovací nástroj), Crop (ořezávací nastroj), Zoom (lupa) a Arrow (šipka). Poslední 4 zmiňované nebudu popisovat, neboť jsou velmi známé a mají velmi intuitivní ovládání.

6.4.1.  Color Replacer (nahrazovač barvy)

Nahrazuje jednu barvu za druhou, a to tím způsobem, že prohazuje barvu, kterou máte nastavenou jako Background color (barvu pozadí) za Foreground color (barvu popředí) s tolerancí, kterou máte nastavenou v Tool Options. Může využívat i textury. 
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Obrázek č. 32 ukazuje nastavení tolerance (vlevo je tolerance nastavena na 10, vpravo na 40).

6.4.2.  Scratch Remover (odstraňovač škrábanců)

S tímto nástrojem pracovat, je velmi nepříjemné. Klávesy, které budete nejvíce používat jsou CTRL+Z (Undo – o krok zpět). Zpět k tématu: jak už je v nadpisu, odstraňuje škrábance z fotografií a to tím způsobem, že vezme okolní barvy kolem škrábance a rozmaže je do něho. 

[image: image34.jpg]


Doporučení: když budete upravovat nějaké místo, přibližte si jej co nejvíce a rozdělte si jej na části podle barev a odstínů. Kdyby jste totiž toto neudělali, nanesla by se vám do tmavé barvy světlá a naopak.  

6.4.3.  Flood Fill (kyblík)

[image: image35.jpg]


Vyplní označenou oblast, popřípadě celý obrázek danou barvou s určitou tolerancí, texturou, popřípadě nastaveným stylem na panelu barev. Umí pracovat pouze s rastrovými vrstvami (viz kapitola č. 7. – vrstvy).   

Blended mode

Vyplývá z vrstev, míchá aktuální vrstvu s vrstvami, pod ní ležící, s nastaveným stylem. 

Match mode

Toto nastavení slouží kyblíku k rozpoznání, jakou barvu má překrýt, a kterou má brát jako ohraničení. 

Tolerance

Říká kyblíku s jakou tolerancí má vykreslovat. Dobrý příklad tolerance je vidět na obrázek č. 32 (Color replacer).

Opacity 

Stejné jako u štětce.

6.4.4.  Deformation Tool (deformační nástroj)

Pracuje obdobně, jako Object Selector v režimu označení, až na to, že se nejedná o vektorovou, ale o rastrovou vrstvu. Musí se jednat o aktivní rastrovou vrstvu, ale nesmí se jednat o vrstvu pro pozadí (Background). 

Doporučení: jestliže chcete modifikovat nějakou část obrázku, který se skládá pouze z vrstvy Background, označte tuto část obrázku a v menu > Selections > dejte Promote to Layer. A poté už jen Deformation...

6.4.5.  Picture Tubes (obrázkové tuby)

Tvůrci PSP už v páté řadě PSP vytvořily soubory obrázků, nazvaných Picture Tube a nástroj na jejich vkládání. Tyto obrázky mohou být vkládány v určité posloupnosti (dle nastavení), a díky tomu se dá snadno a rychle vytvořit např. lano, tráva, louka plná květů... Tyto tuby jsou ukládány ve formátu .tub a můžete si je prohlédnout v browseru v PSP. Proč zrovna tuba? Asi proto, že stačí zmáčknout, a z tuby se vykreslí obrázek s určitými kvalitami, se kterým se nemusíme pracně dělat. 

6.4.5.1.  [image: image36.jpg]& Imag... R [a]|




Nastavení tuby
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V Tool Option si můžete vybrat jakou tubu použijete. Scale je velikost tuby a Step je podobně jako u štětce, a říká, po kolika bodech se vloží objekt z tuby. Ve druhé záložce naleznete Option – další nastavení. Tento dialog je na obrázku č. 36. Zde si můžete nastavit způsob umístění objektu, způsob jak se bude objekt vkládat z tuby. Toto nastavení si můžete uložit jako výchozí.

6.4.5.2.  Tvorba vlastních tub

Tuby si můžeme vytvářet sami a dají se sdílet i s lidmi na webu (lze nalézt i zde nějaké hotové ke stažení). V adresáři Tubes se skrývají tuby, kam se též exportují. 

Postup

a) Vytvořte si nový obrázek s průhledným pozadím (Transparent), s velikostí jakou potřebujete. 

b) Nyní si zobrazte mřížku a nastavte ji velikost buněk, podle toho, jak velké mají být. Při velikosti obrázku 400x300, když nastavíte velikost buňky na 100x100, získáte 12 buněk (nastavení a práce s mřížkou je v kapitole č. 5.2. ). 

c) [image: image38.jpg]VRSTVY V OBRAZKU




Nyní do každé buňky vložte obrázek (tato práce je vidět na obr č. 37). 

d) Export do Picture Tuby provedete v menu > File > Export > Picture Tube. Objeví se vám dialog, který je velmi podobný Picture Tube Option (obrázek č. 36). Nastavte počet buněk, délku kroku. Placement a Selection mode nejsou tak důležité položky, neboť se dají kdykoliv při použití tohoto nástroje změnit. Položka, která tu přibyla je název Tuby. Potvrďte a máte hotovou tubu, která se automaticky přidá do patřičného adresáře tub, a bude též přidána nová položka do seznamu tub v Tool options.   

7.  VRSTVY
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Vrstva je plocha, která má stejnou šířku a výšku obrázku a ovlivňuje jeho celkový vzhled. Můžeme si představit, že vrstva je papír, na kterém je nakreslena část obrázku, a zbytek je průhledný. Jestliže máme více vrstev, pak se jednotlivé papíry překrývají dle toho, jak je máme poskládané na sobě. Všechny tyto vrstvy ve správném pořadí skládají dohromady obrázek.  Na obrázku č. 38 je tato představa dobře vidět. 

V Paint Shop Pro můžete vytvořit tři typy vrstev. Raster layers (rastrové vrstvy), vector layers (vektorové vrstvy), adjustment layers (přizpůsobovací vrstvy). Rastrové vrstvy obsahují informace pro jednotlivé pixely, vektorové vrstvy obsahují data pro kreslení vektorových čar, tvarů a textu. Vektorové kreslící nástroje jsou: Draw, Text, Preset Shapes). Označení vektorových vrstev se provádí pomocí Object Selector – viz kapitola č. 6.2.4. Přizpůsobovací vrstvy obsahují informace pro korekci barev, používají se pro vzezření vrstvy pod nimi ležící. 

Pokud někdy budete potřebovat smíchat, buď všechny vrstvy, popřípadě smíchat všechny viditelné, naleznete tuto funkci v menu > Layers > Merge > Merge all (Flattern) / Merge Visible. Vytvoří se jediná vrstva, buď s názvem Background, nebo vrstva Merged (obě typu Raster Layer).

7.1.  Omezení vrstev

7.1.1.  Rastrové a přizpůsobovací vrstvy

Pro práci z rastrovými a přizpůsobovacími vrstvami musíte použít stupně šedi (gray scale), nebo 24 bitovou hloubku barev. Na tyto vrstvy můžete aplikovat efekty (menu > Effects). Pokud máte aplikovaný nějaký výběr (Selection), tak se efekt aplikuje pouze na tu část aktivní vrstvy, která je ve výběru. Pokud obrázek nemá žádný výběr, efekt se aplikuje na celou aktivní vrstvu.

7.1.2.  Vektorové vrstvy

Vektorové vrstvy nemají barevné omezení, ale nemůžeme na nich aplikovat efekty.  

7.2.  Paleta vrstev
Tento velice používaný pomocník si můžete zapnout pomocí klávesy L, nebo View > Toolbars > Layer Palette. Tento panel je rozdělen na 2 části. 

7.2.1.  Levá část

Je zde seznam vrstev, u každé vrstvy je ikonka, která ukazuje, o jako vrstvu se jedná.

7.2.2.  Pravá část

Zde jsou záložky nastavení jednotlivé vrstvy. Záložka vzhledu má na starosti neprůhlednost (Opacity, dalo by se též chápat i jako průsvitnost), režim smíchání (Blend mode), a průhlednost (Transparency) jednotlivých vrstev. Záložka masky umožňuje připojit masku k jednotlivé vrstvě. Záložka skupiny nastavuje do jaké skupiny má patřit daná vrstva.    
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7.3.  Dialog vlastnosti vrstvy

Vyvoláte 2-mi způsoby:  pravé tlačítko na vrstvě v dialogu Paleta barev nebo menu > Layers > Properties

V tomto dialogu naleznete tytéž nastavení jako na paletě vrstev. Jen u přizpůsobovací vrstvy zde přibude nová záložka Adjustment, kde je nastavení dle toho, jaký typ přizpůsobovací vrstvy máte.

7.4.  Kreslíme pomocí vrstev

Následujícím příkladem vám ukáži jednu z možností, jak kreslit pomocí vrstev. Nakreslíme si tlačítko pro web. 

1) Vytvoření obrázku a přidání textury
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Vytvořte si nový obrázek o velikosti 100x100 bodů ve 24 bitové barevné hloubce s bílým pozadím. Vyplňte jej pomocí kyblíku (Flood Fill) s nastavením: Blended mode - Normal, Match mode - RGB value, Opacity - 100, Tolerance - 0,  libovolnou texturu (já jsem použil Wrap), vykreslenou pomocí černé a plné (Solid) barvy. Vytvořte si rastrovou vrstvu, označte ji jako aktivní. Vezměte kreslící nástroj Selection, nastavte kruh (Circle), Feather - 0 a zaškrtněte Antialias. Vytvořte uprostřed obrázku kruhový výběr selekci. Tuto selekci si uložte do abecedního kanálu (Selections > Save to Alpha Channel). Nechejte výběr (Selection) aktivní. 

2) Vyplnění výběru a nastavení vrstvy

Vytvořte si další vrstvu, opět označte jako aktivní. Zvolte menu > Selection > Modify > Feather – 6. Nastavte si barvu popředí na bílou, barvu pozadí na černou,  ve Styles (na panelu barev) > Gradient > Foreground – Background, s nastavením Angle 120. Vyplňte pomocí kyblíku výběr. 
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Prohlubeň
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Opět vytvořte novou vrstvu, načtěte výběr a nastavte výběru Feather – 6 a ve stejném menu i Contract – 10. Nyní pomocí kyblíku vyplňte výběr se stejným nastavením jako v bodě 2, pouze prohoďte barvy (z černé do bílé).

4) Vrchní část

[image: image44.jpg]


Přidejte novou vrstvu, a načtěte si výběr. Nastavte Contract – 14 a znovu uložte výběr do abecedního kanálu (Save to Alpha Channel). Nyní si nastavte typ Gradientu (sklonu) na Sunburst (stejný dialog, kde jste nastavovali Angle – bod 2. Nastavte zde Horizontal a Vertical na 33. Vyplňte výběr kyblíkem a nezapomeňte opět prohodit barvy z bílé do černé. 

5) Stín
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Již naposledy si vytvořte novou vrstvu a načtěte výběr, ale tentokrát ten druhý v pořadí. Běžte do menu > Effects > 3D Effects > Cutout s následujícím nastavením: Shadow color = black, Opacity = 100, Blur 20, Vertical a Horizontal = 0. Nastavte v paletě vrstev, v záložce vzhledu na Hard Light a Opacity na 50 (místo 100). 

Obrázek č. 45 ukazuje paletu vrstev pro ujasnění předcházejícího příkladu.

8.  UKLÁDÁNÍ OBRÁZKŮ – Save / Save as

Pokud v PSP použijete příkazu Save / Save as, zobrazí se Vám dialogové okno (na obrázku č. 46). Je zde mnoho formátů, které si můžete zvolit. Některé jsou více známé některé méně. U většiny z nich si je můžete nastavit. Jedná se např. o Compressed (zabalený – většinou ztráta kvality), nebo Uncompressed (nezabalený). Pro publikování na webu jsou zde 3 typy výstupních formátů a to: jpg, gif, png, avšak během práce je dobré pracovat s formátem psp. Tento formát jako jediný podporuje ukládání vrstev, označení, a všechny další rysy editoru PSP. Při ukládání obrázku, kde máte použity vrstvy, se vás editor zeptá na potvrzení, zda se mají vrstvy smíchat.  

8.1.  Trocha teorie o webových formátech 

8.1.1.  Gif

Používá se pro obrázky, které mají velmi málo barev. Je totiž omezen horní hranicí 8 bitů, což znamená 256 barev. K výběru máme 2 verze: 87a a 89a. Verze 89a podporuje průhledné pozadí, a může v něm být uložena animace (což je posloupnost obrázku vytvořena např. v Animation Shopu), která se říká tzv. animovaný gif. 

Umožňuje také výběr z dalších dvou položek. Tyto položky jsou Interlaced a Noninterlaced, mají význam pro web a to tím způsobem, že když je obrázek uložen jako Noninterlaced, je načítán do Internetového prohlížeče postupně od jeho horní části dolů. Když je Interlaced tak je do prohlížeče natahována takto: zobrazí se rozmazaný (nekvalitní) a je postupně vylepšován, dle toho jak je natahován do prohlížeče. Konečný výsledek obou způsobů vypadá stejně…

8.1.2.  Jpg

Používá se převážně pro fotografie a je velmi oblíbený ne webu. Podporuje 24 bitovou hloubku barev, což v přepočtu znamená 16,7 mil. barev. Umožňuje stupně komprese, ale tato komprese je ztrátová. Čím větší komprese, tím nekvalitnější obrázek, ale menší velikost. Doporučuji si vybrat průměr mezi kvalitou a velikostí souboru. S porovnáním s formátem gif nepodporuje průhledné pozadí.

Opět jako Gif umožňuje výběr ze dvou položek, ale tentokrát z Progressive a Standart. Standart je stejný jako Noninterlaced u Gifu, ale Progressive má o malinko vylepšené natahování do prohlížeče vůči Interlaced u Gifu. 

8.1.3.  Png

Nový formát, který přibyl od verze PSP 6.0. Je to formát vytvořený pro Internet a pro jiné sítě, který je používán hlavně k ukládání bitmapových obrázků. Ale zobrazit jej mohou pouze nové verze prohlížečů Internet Explorer a Netscape, přičemž nemají plnou podporu těchto obrázků. Tento formát umožňuje abecední průhlednost (alpha transparency), má kvalitnější kompresi, než gif, a umožňuje 16,7 mil. barev jako jpg. Umožňuje jako gif Interlaced a Noninterlaced.
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Doporučení: dokud nebude mít tento formát plnou podporu prohlížečů, nevyužívejte jej.

U formátů Gif, Jpg a Png je možnost kompletně nastavit výstup do těchto formátů (stupeň komprese, konverze barev, ...). K tomuto způsobu uložení se dostanete více způsoby. 

a) menu > Export > Jpg, Gif, Png Optimizer

b) panel Web toolbar 

c) asi nejlepší způsob: Save as (zde vyberte typ) > Options > Run Optimizer

8.2.  Gif Optimizer
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Na první pohled je tento dialog velmi složitý, ale není tomu tak. Obsahuje 5 karet. Můžete volit Transparency - Partial Transparency (plná či částečná průhlednost), Colors (barvy, včetně redukce barev), Format (způsob načítání do prohlížeče), Download Times (tato karta poskytuje orientační tabulku časů, nutných ke stažení obrázku do prohlížeče). V oblasti Uncompressed je originál, který upravujete a v oblasti Compressed je vidět výstup se všemi změnami, které v nastavení uděláte. Proto tedy nebudu tento dialog vysvětlovat. Pokud si přesto myslíte, že je tento dialog příliš složitý, zkuste použít ze začátku průvodce (Use Wizard), ale bohužel v průvodci není vše.... 

8.3.  Jpg optimizer

Tento dialog Vám zprostředkuje uložení obrázku do formátu jpg nebo jpeg. Je velmi podobný předchozímu Gif Optimizeru, ale má jen 3 záložky. 

a) Quality (kvalita) zde si můžete nastavit velikost komprese

b)  Format (způsob načítání do prohlížeče), 

c) Download Times možnost prohlédnout si tabulku časů potřebných ke stažení do prohlížeče. 
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8.4.  PNG optimizer

Jako předchozí 2 dialogy je i tento velmi podobný. Tentokrát 4 karty: Colors (barvy, včetně redukce barev), Transparency (průhlednost, včetně abecední), Format (způsob pozdějšího načítání do prohlížeče), Download Times (možnost prohlédnout si tabulku časů potřebných ke stažení do prohlížeče). 
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9.  Batch Conversion (dávková konverze)

Tato funkce je velmi užitečná. Tuto funkci naleznete ve File > Batch Conversion. Jistě jste už někdy měli problém převést více souborů do jiného formátu. Nejspíš Vám nezbylo nic jiného, než trpělivě převádět obrázek po obrázku. 

Díky této funkci si pouze označíte obrázky k převodu, a nastavíte výstupní formát, adresář a o zbytek se postará PSP. Tato funkce již byla v PSP 5. Dialog přikládám na obrázku č. 50. Nevýhodou je, že si nemůžete nakonfigurovat Optimizer (jpg, gif, png), ale pouze můžete nastavit základní výstup souborů.
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10.  Web toolbar
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Jakožto většina funkcí v PSP, je i Web toolbar přístupný pouze při aktuálně otevřeném obrázku. Položky Jpg, Gif, Png Optimizers byly již popsány. Panel zapnete v menu > View > Toolbars, kde zaškrtnete položku Web Toolbar. Nebo je druhá možnost, kliknout pravým tlačítkem na nějaký z panelů (ale ne na nějakou funkci), vyberte položku Web Toolbar. Zobrazí se Vám panel (viz obr. č. 51).

10.1.  Image Mapper (generátor klikacích map) 
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Toto je jedna z novinek v Paint Sho Pro 7. Díky této funkci můžete snadno a rychle vygenerovat klikací mapu na internetové stránky (htm, html). Kdyby jste neměli po ruce nějaký generátor, který vám vytvoří klikací mapu, a měli jste ji zadávat ručně, potom by tato činnost zabrala mnoho času a úsilí.  Pro nezasvěcené: jedná se o oblast (oblasti) na obrázku, které jsou citlivé na kliknutí myši (a nejen to). 

10.1.1.  Popis položek

10.1.1.1.  Tools (uvedu jen nejasné)

Šipka: označí mapku a načte její nastavení (URL, ...)

Posun mapy: nejedná se o posun obrázku, ale posun vytvořené klikací mapy!

Tvary: jedná se o tvary klikací mapy (poligonální – z bodu do bodu, čtverec, kruh)

Vymazání: vymazání klikací mapy

10.1.1.2.  Rollover Creator

V této funkci je možné pro danou oblast vytvořit určitou vlastnost. Např. po najetí kurzorem myši v prohlížeči, se může změnit obrázek v nějaký jiný, ale celý! Tudíž nemá význam pro velké obrázky, neboť by tato událost trvala velmi dlouho (musel by se velký obrázek změnit v jiný, nebo-li natáhnout do prohlížeče). Tato položka má u klikací mapy význam, pouze u malých obrázků (např. tlačítka), když nevíte, nebo se vám nechce dělat tyto tlačítka „ručně“... Pozn. pokud budete tuto funkci využívat, používejte obrázky se stejnou velikostí.

10.1.1.3.  Object Properties (nastavení aktuálně označené mapky)

URL: adresa, kam bude směřovat klikací mapa (např. http://www.ceska-trebova.cz).

Alt text: popisek dané mapky, který se zobrazí po najetí myši

Target: říká prohlížeči do jakého okna či rámu má otevřít danou adresu

_blank pro dokument vždy využít nové okno

_parent zobrazit dokument v rámu či okně, ve kterém je zobrazen nejbližší nadřazený    

_self zobrazit v tomto okně (ruší účinek atribitu target ve značce <BASE>)

_top pro zobrazení použít celé okno prohlížeče (ruší rozdělení okna na rámy) 

Left, Right, Top, Bottom: (zleva, zprava, ze shora, ze spodu) – aktuální pozice kurzoru

10.1.1.4.  Formát

typ obrázku (Gif, Jpg, Png)

Obtimize Image: nastavení formátu obrázku

10.1.1.5.  Zbývající položky

Save Settings / Load Settings: vytvořenou klikací mapu si můžete uložit (např.: z důvodu, že si potřebujete upravit obrázek, nebo je tak obsáhlá, že v práci budete pokračovat až následující den) na disk a následně pak načíst (koncovka .jmd). Nejedná se o obrázek!
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Prohlédnout klikací mapku: spustí se výchozí prohlížeč 

s editovanou mapkou

Clear: vymaže vše, kromě editovaného obrázku

Save / Save as: uložit / uložit jako...

Preferences: nastavení barvy pro vytvořené klikací mapy, a kolik kroků zpět si má pamatovat dialog

10.1.2.  Výstup generátoru – HTML soubor 

Tento výstup se vztahuje k obrázku č. 52.

<HTML>

<HEAD>

<META NAME="Author" CONTENT="Martin Krpata">

<META NAME="Generator" CONTENT="Jasc Paint Shop Pro 7">

<TITLE>
</TITLE>

</HEAD>

<BODY>

<IMG NAME="mapa0" SRC="mapa.png" WIDTH="385" HEIGHT="309"   

   BORDER="0" USEMAP="#mapa">

<MAP NAME="mapa">

<AREA SHAPE="circle" 

   COORDS="252,227,6"   

   HREF="http://Lanskrounsko.cz" 

   TARGET="_top" 

   ALT="Lanškroun">

<AREA SHAPE="rect" 

   COORDS="151,196,218,213"  

   HREF="http://www.ustinadorlici.cz/" 

   TARGET="_top" 

   ALT="Ustí nad Orlicí">

<AREA SHAPE="poly" 

   COORDS="174,226,191,218,236,223,242,248,187,248,186,240,   

   174,240" 

   HREF="http://ceska-trebova.cz" 

   TARGET="_top" 

   ALT="Česká Třebová">

</MAP>

</BODY>

</HTML>

10.2.  Image slicer (rozřezávač obrázku) a Animation shop

Opět další novinka vůči verzi PSP 6.0. Image slicer (jak už z překladu vyplývá) slouží k rozřezání obrázků, a následného uložení do HTML verze, kde tento obrázek je znovu poskládán pomocí tabulky. Tento rozřezávací nástroj a generátor HTML kódu umí i udělat tzv.: rollover tlačítka. Čeho se tím dá dosáhnout? To je jednoduché, např. když potřebujete udělat z obrázku tlačítka, nebo z části obrázku udělat animovaný gif, který se může zobrazit např. po najetí myši, dvojkliku, ....

Některé funkce, či položky jsou stejné jako u generátoru klikací mapy (kapitola č. 10.1. ), a proto se o nich nebudu zmiňovat.

10.2.1.  Popis položek

Vztahuje se k obrázku č. 53.

10.2.1.1.  Tools

Šipka: označí část (buňku) tabulky

Grid: vytvoří tabulu, po kliknutí na obrázek se zobrazí dialog na zadání sloupců (Columns) a řádek (Rows)

Slicer: nástroj pro ruční rozřezání tabulky
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Delete: nástroj na odmazání určitých částí tabulky (pokud to je možné - kontrola)

10.2.1.2.  Rollover Creator

Po určité události, která se týká myši, se změní citlivá část obrázku (buňka tabulky). 

Mouse over: přejetí kurzoru myši přes citlivou oblast

Mouse out: kurzor myši mimo citlivou oblast

Mouse click: kliknutí na citlivou oblast

Mouse double click: dvojklik na citlivou oblast

Mouse up: puštění stlačení tlačítka myši nad citlivou oblastí

Mouse down: jakékoliv zmáčknutí tlačitka myši opět nad citlivou oblastí

U všech těchto činností si musíte vybrat obrázek, ve který se má citlivá oblast změnit (doporučuji stejnou velikost – jinak se bude celý obrázek rozpojovat).

10.2.1.3.  Cell Properties

Include cell in table: pokud je zaškrtnuté, je možnost tvořit pomocí buněk tabulky URL odkazy

10.2.1.4.  Zbývající položky

Save Settings / Load Settings: stejné jako u generátoru klikací mapy, pouze ukládáte / načítáte nastavení vytvořené tabulky.

10.2.2.  Příklad využití Image Sliceru a Animation Shopu

Pro objasnění a pro částečné vysvětlení Animation  Shopu, který je přílohou PSP, uvedu příklad. Použiji mapu okresu Ústí nad Orlicí, kde budu chtít zvýraznit obec Třebovice. Na tomto místě použiji i rollover funkci, kterou se zaktivuje animovaný gif.

1) Rozřezání obrázku a získání části obrázku.

Otevřete si obrázek a spusťte Image Slicer. Proveďte rozřezání (viz. obrázek č. 53), nastavte výstup obrázku na Gif a spusťte Optimize Cell. Nastavte si výstup obrázku, dle kvality, jakou chcete mít. Já jsem použil: Transparency: None, Colors: Optimized Median Cut (256 barev), dithering 100%, Include Windows colors: nezaškrtnuté), Format: interlaced.

2) Uložení na disk

Použijte tlačítko Save Settings a uložte si nastavení tabulky (budete jej v budoucnu potřebovat). Nyní si uložte aktuální rozřezání pomocí Save. Vytvořte si novou složku a uložte do ní html soubor (obrázky dostanou automaticky vygenerovaný název).

3) Otevření části obrázku

Otevřete si část obrázku, kterou chcete vylepšit (u mě je to oblast Třebovice – doporučuji pomocí File > Browse). 

4) Jednotlivé sekce pro Animation Shop

Nyní si musíme připravit obrázky pro Animation Shop. Označte si tento obrázek, zvyšte počet barev (Increase Color Depth) a vložte jej tolikrát, kolik předpokládáte, že bude mít animace snímků – pomocí CTRL+V (Paste as New Image). Nyní si je upravte postupně, tak jak chcete, aby daná animace vypadala (např. viz obrázek č. 54). 

[image: image56.jpg]



5) Vkládání do Animation Shopu
Vyberte první obrázek a označte jej (např. pomocí CTRL+A) a zkopírujte do schránky (CTRL+C). Spusťte si Animation Shop a zmáčkněte kombinaci kláves CTRL+V (nebo Edit > Paste > As New Animation). Vytvoří se Vám nová animace, ve které bude jako první váš obrázek. Nyní se vraťte do PSP a zkopírujte do schránky 2 obrázek. V Animation Shopu ho vložte pomocí kláves SHIFT+CTRL+L (nebo Edit > Paste > After Current Frame). Tuto činnost opakujte tolikrát, až do té doby, dokud tam nebudete mít vložené všechny obrázky v řadě. Pak to bude vypadat např. jako obrázek č. 55.
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6) Prohlédnutí animace

Nyní si můžete danou animaci prohlédnout (View > Animation). Pokud nejste spokojeni s dobou trvání jednotlivých částí animace, můžete si ji přednastavit. Označte si jeden z obrázků a použijte zkratkovou klávesu ALT+ENTER (nebo pravým tlačítkem na daný obr. a volba Frame Properties. Hned v první záložce je doba zobrazení (Display time). 

7) Uložení animace 

Zvolte File > Save As, vyberte výstup formátu obrázku GIF. Po odkliknutí tlačítka Save se objeví Dialog „Animation Quality Versus Output Size“. Zvolte Customize a nastavte zde obdobné nastavení jako u bodu č. 1). (256 barev, Optimized Median Cut, Nearest Color). Jako další 2 záložky po potvrzení, jsou porovnání kvality originálu vs. kvality výstupu, stahovácí časy.

8) Návrat do PSP, vytvoření rollover tačítka 

Nyní si můžete zavřít Animation Shop a vraťte se zpět do PSP. Znovu si otevřete originál obrázku (celkového). Spusťte si Image Slicer a načtěte si uložené nastavení tabulky (Load Settings). Nyní vyberte pomocí nástroje šipka upravovanou čast obrázku (u mě to je Třebovice). Vyberte funkci Rollover Creator a vyberte funkci Mouse over, a jako obrázek dejte vaši vytvořenou animaci. Jako druhou fci zvolte Mouse out a zde zvolte původní výřez oblasti (stejnou jako v bodě 3).

9) Uložení výtvoru 

Musíte znovu nakonfigurovat výstup souboru, udělejte stejně jako v bodě 1, nastavte Cell properties a uložte. Pokud si chcete prohlédnout Váš výtvor než uložíte, zvolte obrázkové tlačítko Preview in browser. 

10)  Vzhled a popis

Při spuštění HTML souboru bude obrázek vypadat tak, jako by jsme tam vložily původní celý (pokud to nebudete načítat z internetu pomalou linkou). Při najetí kurzorem na citlivé místo se zobrazí popisek (Alt), citlivá část se změní v animaci, při vyjetí kurzoru z citlivé oblasti se zobrazí původní část. Po kliknutí na citlivé místo budete přesměrováni na danou adresu.

10.2.3.  Výstup generátoru – HTML soubor

Tento výstup se vztahuje k předchozímu příkladu.

<HTML>

<HEAD>

<META NAME="Author" CONTENT="Martin Krpata">

<META NAME="Generator" CONTENT="Jasc Paint Shop Pro 7">

<TITLE>
</TITLE>

</HEAD>

<BODY>

<!-- Begin Table -->

<TABLE BORDER="0" CELLPADDING="0" CELLSPACING="0"    

WIDTH="385" 

HEIGHT="309">

<TR>

<TD ROWSPAN="1" COLSPAN="3" WIDTH="385" HEIGHT="250">

<IMG NAME="Uo0" SRC="Uo_1x1.gif" WIDTH="385" 

HEIGHT="250" BORDER="0"></TD>

</TR>

<TR>

<TD ROWSPAN="1" COLSPAN="1" WIDTH="190" HEIGHT="16">

<IMG NAME="Uo1" SRC="Uo_2x1.gif" WIDTH="190" 

HEIGHT="16" BORDER="0"></TD>

<TD ROWSPAN="1" COLSPAN="1" WIDTH="66" HEIGHT="16">

<A HREF="#"  onMouseOver="if(document.images)  

document.Uo2.src='Animation.gif';" 

onMouseOut="if(document.images) document.Uo2.src='Uo_2x2.gif';">

<IMG NAME="Uo2" SRC="Uo_2x2.gif" WIDTH="66" 

HEIGHT="16" BORDER="0">

</A></TD>

<TD ROWSPAN="1" COLSPAN="1" WIDTH="129" HEIGHT="16">

<IMG NAME="Uo3" SRC="Uo_2x3.gif" WIDTH="129" HEIGHT="16" BORDER="0"></TD>

</TR>

<TR>

<TD ROWSPAN="1" COLSPAN="3" WIDTH="385" HEIGHT="43">

<IMG NAME="Uo4" SRC="Uo_3x1.gif" WIDTH="385" 

HEIGHT="43" BORDER="0"></TD>

</TR>

</TABLE>

<!-- End Table -->

</BODY>

</HTML>
11.  Jak nakreslit...

V této kapitole vám ukáži jedny z mnoha způsobů, jak kreslit nadpisy a tlačítka pro web. Už jsem vám ukázal, jak můžete využít kreslící nástroj Preset Shapes, a jak kreslit pomocí vrstev. Rozhodl jsem se nepopisovat efekty, kterých má PSP velmi mnoho, ale předvedu vám nejpoužívanější, díky následujícím příkladům. 

11.1.  Nadpisy

Druhů nadpisů je celá řada. Od nejjednodušších, kde je obyčejný text vyplněný nějakým stylem, a k tomu přidaný efekt Drop Shadow (stín). Tyto nadpisy nevypadají špatně, ale jsou i složitější. Nyní vám ukáži jak se dá jeden z nich vytvořit.

11.1.1.  Rozmazaný nadpis

Díky použití Airbrush tool a efektu Hot Wax Coating můžete dosáhnout velice pěkného nadpisu.

a) krok 1 

Založte si nový obrázek s 16 miliony barev a velikostí 400x200 bodů. Nastavte bílou barvu pozadí. 

b) krok 2
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Zvolte nástroj Text a napište do dialogu libovolný text s libovolným fontem. Já použil Comic Sans MS s velikostí 70 bodů, neboť se s velkými fonty dobře pracuje, díky nim jsou totiž dobře viditelné textury. Dále nastavte v položce Create as – Selection. Po potvrzení Vám vznikne něco podobného jako obrázek č. 56. Nerušte výběr (selection)! 

c) krok 3 

Vyberte nástroj Airbrush (sprej) a v Tool Options nastavte následující toto: Shape – Round, Size – 40, Hardness – 0, Opacitu – 50, Step – 15 a Density 100. Barvu popředí nastavte na R:255, G:0, B:0. Udělejte rychlý pohyb sprejem po horní části výběru. Dále nastavte barvu popředí na R:0, G:0, B:255 a udělejte to samé, po dolní části výběru. Opět přednastavte barvu popředí na R:255, G:255, B:0, a tentokrát obarvěte prostřední část výběru. Když se to nepovede na poprvé, tak se nic neděje, máte vždy možnost se o pár kroků vrátit [image: image59.jpg][=[Ofx]
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zpět (Undo – Ctrl+Z).

d) krok 4

Opět nastavte barvu popředí na bílou a aplikujte efekt Hot Wax Coating (horký vosk) – tento efekt najdete v: Effects > Artistic Effects >  Hot Wax  Coating. Jako další aplikujte efekt: Cut Out. Ten naleznete v: Effects > 3D Effects > Cut Out. Nastavte: Fill Interior nezaškrtnutý, Shadow Color – bílou, Opacity 100, Blur 5, Horizontal a Vertical offset na 3 – potvrďte. Další efektem získáme stín: Effects > 3D Effects > Drop Shadow. Tento efekt nastavte na: Color černou,  Opacity 100, Blur 9, Horizontal a Vertical offset na 5. 
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Je vidět, že se dá velmi jednoduše a rychle udělat pěkný nadpis. Tento způsob má mnoho kombinací, stačí např. nastavit před aplikováním efektu Hot Wax Coating místo bílé barvy popředí nějakou jinou, nebo prohodit barvu pozadí a barvu stínu (záleží na vkusu a na použití)…

11.2.  Tlačítka

Nejednoduší kreslení tlačítka je pomocí Preset Shapes. Ale pokud si takové tlačítko chcete nakreslit sami, uvádím jednu z možností. 

11.2.1.  Tlačítko pro web

Nyní bych vám rád ukázal, jak vytvořit velice zajímavé a hezké tlačítko pro web. Bude se opět jednat o tlačítko složené z mnoha vrstev. Použiji na jeho výrobu tužku, kyblík, efekty Cutout, Soften, …    

11.2.1.1.  Vytvoření základního tvaru

Vytvořte si nový obrázek o velikosti 300x100 s bílým pozadím. Nastavte plnou barvu popředí na černou a vyberte kreslící nástroj tužka (Draw). V Tool Options nastavte tloušťku (Width) na  70, zaškrtněte Antialias a Create as vektor, zvolte rovnou linku. Klikněte na Custom a nastavte dialog dle obrázku č. 59. 
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Nakreslete linku pomocí klávesy Shift (zaručí rovnost). Tento výsledek je vidět na obrázku č. 60.
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11.2.1.2.  Dotvoření základu
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Nyní pomocí Layer Palette vytvořte duplikát této vrstvy. V menu > Layers > zvolte Convert to Raster Layer. Pomocí Magic Wand označte tlačítko. Uložte toto označení do Alpha Channel ( v menu > Selections > Save to Aplha Channel). Vytvořte novou rastrovou vrstvu a načtěte označení z Alpha Channel. Vyplňte pomocí kyblíku barvou, ze které se bude skládat tlačítko. Já použil R:66, G: 115, B: 165. Výsledek je vidět na obrázku č. 61. 

11.2.1.3.  Světlá část tlačítka
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Vytvořte další vrstvu a načtěte si znovu označení. V menu > Selections > Modify > požijte Contract – 10, Feather – 10. Vezměte kyblík a vyplňte označení bílou barvou. Aplikujte efekt Gaussian Blur – 10 (naleznete v menu > Effects > Blur). Vemte nástroj Mover a posuňte bílou část o malý kousek dolů. Vidět lze na obrázku č. 62.

11.2.1.4.  Vytvoření vnitřního stínu  
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Nastavte poslední vytvořené vrstvě v pravé části Layer Palette místo Normal – Dodge a Opacity nastavte na 40. Vytvořte opět rastrovou vrstvu a nyní vytvořte vnitřní stín. V menu > Effects > 3D Effects zvolte efekt Cutout a nastavte jej na: Fill interior nezaškrtnutý, Opacity 30, Blur 30, Shadow color na černou Vertical a Horizontal na 0. Výsledek je na obrázku č. 63.

11.2.1.5.  Přidání vrchního nasvícení  
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Opět načtěte označení za Aplha Channel, a použijte Contract – 5. Nyní zvolte označovací nástroj výběr (Selection) a nastavte obdélníkový tvar (Rectangle). Pomocí klávesy Ctrl a nástroje pro výběr odřízněte spodní část označení. Vezměte nástroj kyblík a nastavte plnou barvu pozadí na bílou. Ve Styles zvolte linear Gradient s nastavením: Angle 180, Fading Background. Vyplňte, odznačte výběr pomocí Ctrl+D a zvolte efekt Soften (na stejném místě jako Gaussian Blur). Výsledek snažení je na obrázku 64. 

11.2.1.6.  Doladění tlačítka
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Vytvořte další rastrovou vrstvu, načtěte označení a zvolte efekt Cutout s nastavením Fill Interior nezaškrtnutý, Opacity 80, Blur 30, Shadow Color černou, Vertical a Horizontal 0. Nastavte tuto vrstvu z Normal na Burn a Opacity nastavte na 75. Vytvořte další vrstvu, opět načtěte označení a znovu aplikujte efekt Cutout, ale tentokrát s tímto nastavením: Fill Interior nezaškrtnutý, Opacity 100, Blur 10, Shadow Color bílou, Vertical a Horizontal 0. Odznačte označení a máte hotové tlačítko, na které stačí přidat text a dát na vaše internetové stránky… 

12.  Praktická část

Mojí praktickou částí bylo vytvořit www prezentaci pro obec Třebovice v Čechách. Na stránky obce jsem použil jen minimum z toho co umí PSP, ale i tak si myslím, že tyto stránky zviditelní obec, a že scela splní svůj informační účel. Bohužel, se ale bude jednat nejspíše o stránky statické, beze změn, neboť obec nemá zájem uvádět na těchto stránkách aktuality. Ty vydávají ve formě černo–bílého časopisu, jako měsíčník. Stránky jsou umístěné na adrese www.trebovice.cz
Už od začátku jsem se potýkal s nedostatkem informací, které mi poskytla obec, pro vytvoření stránek. Veškeré údaje jsem musel zpracovávat, a to i včetně historie, kterou jsem čerpal z místních dvou kronik. Bohužel, ale i tyto záznamy nebyly kompletní, neboť v padesátých letech na národním výboru hořelo. 

Internetové stránky jsem tvořil v editoru Homesite, a grafiku jsem vypracoval v PSP, včetně upravených fotografií, které mi zapůjčil p. starosta k digitalizaci.  

13.  Závěr

Myslím si, že program Paint Shop Pro 7.01, je velmi kvalitním grafickým editorem a mezi Shareware programy nemá konkurenci. Každá verze v sobě přináší velký skok kupředu a myslím si, že verze 7.01 není konečnou verzí. 

Než jsem začal pracovat na absolventské práci, dal jsem si za úkol vytvořit částečný manuál k PSP, zaměřený na popis jeho možností, vytvářet grafiku pro webdesign. Jest-li se mi povedlo splnit zadaný úkol, musí říci čtenář, lépe řečeno uživatel, který bude čerpat inspiraci z tohoto textu.
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G
vložit jako novou vektorovou vrstvu

R
natočit (výběr, obrázek)

N
nový obrázek

O
open dialog box (otevření obrázku)

B
browser

S
uložit (Save)

Z
o krok zpět

Zobrazení / skrytí panelů

C
panel barev

P
panel kreslících nástrojů

T
zbývající panely

Nástroje

L
paleta vrstev

O
Tool Options

W
Overview window

Další zkratkové klávesy

CTRL + ALT +

R
pravítka

G
mřížka

Z
o krok vpřed

SHIFT + CTRL +

V
nastavit průhlednou barvu (pozadí)
Vypracoval: Martin Krpata 2001

Email: KrpataM@seznam.cz
Bez výslovného svolení autora je zakázáno tuto práci nějak upravovat!
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